Описание продукта альфа авто ред.5

Содержание

Этап 2. Включить возможность изменения конфигурации

Для начала следует разблокировать корневой объект конфигурации для внесения изменений.

Порядок действий следующий:

  1. Сперва убедитесь, что все пользователи завершили свою работу с программой. После чего запустите программу в режиме «Конфигуратор».
  2. Откройте окно настройки поддержки.

  3. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  4. В появившемся окне укажите, что объекты поставщика не редактируются.

  5. Затем для корневого объекта конфигурации установите правило поддержки «Объект поставщика редактируется с сохранением поддержки».

Теперь конфигурация готова к внесению изменений.


2013/08/06 13:54 ·

Отраслевая специфика в 1С Автосервис

Предварительная запись не является обязательной однако позволяет спланировать и распределить загрузку цеха. Увязав заявки на ремонт с заказ-нарядами пользователь получает более полное представление об этапах взаимоотношений с клиентом. Программа позволяет с помощью документа

Центральное место, в надстройке отражающей отраслевую специфику, конфигурации занимает документ “Заказ-наряд”. Этим документом отражаем как приемку автомобиля и передачу его цех. После дефектовки в заказ-наряде можно заполнить товары, воспользовавшись механизмом подбора запчастей. Указав в отдельной табличной части выполняемые работы можно распределить эти работы по исполнителям. И как заключительную часть процесса зафиксировать выдачу авто владельцу.

Перечисляя более подробно возможности конфигурации разработчики пишут:

— Можно учитывать технику принятую на ремонт и находящиеся на предприятии как на стоянке так и цехах автосервиса;

— В документе заказ-наряд можно указать текущее состояние ремонта:

заявка на ремонт;

выполнение работ;

ожидание запасных частей;

выполнен ремонт;

документ заказ-наряд закрыт;

На разных этапах выполнения ремонта могут потребоваться различные печатные формы и документа заказ-наряд и конфигурация 1С Автосервис позволяет сформировать:

  • акт осмотра автомобиля при приемке,
  • рабочий лист для использования в цехе,
  • сам заказ-наряд,
  • квитанцию по заказ-наряду

Примеры печатных форм на рисунке ниже


В случае если встроенные печатные формы не удовлетворят потребностей бизнеса можно разработать новые или доработать уже существующие как это описано в статье.

— Пользователь может сам определить различные виды ремонта отнеся их либо к платному, либо к бесплатному ремонту;

— Отраслевое решение предлагает гибко настроить правила ценообразования на работы;

— Подбор товаров и запчастей можно осуществлять исходя из складских остатков;

— Гибкая настройка управленческих отчетов позволяет контролировать текущие показатели прибыльности;

— Использование в качестве платформы типовой конфигурации УНФ, построенной на управляемых формах

позволяет запускать мобильные приложения и контролировать предприятие через планшетные компьютеры и коммуникаторы;

— Подсистема управления запасами позволяет отразить как покупку товаров подотчетным лицом, так и реализацию комиссионных товаров.

При этом могут быть учтены дополнительные расходы.

В программе может быть учтен весь цикл складских операций с товарными запасами от поступления до реализации.

Выделение товаров купленных, принятых на реализацию, а также ценностей на ответственном хранении.

В конфигурации 1с Автосервис на ряду с другими отраслевыми решениями доступен механизм определяемых пользователем свойств и характеристик

Также в конфигурацию включен механизм «ордерного склада».

— Реализация товаров:

отработанная схема отражения продажи в розницу с использованием Рабочего места кассира (РМК) и подключением торгового оборудования


а также оптовой торговли и поступления

Раздел учета денежных средств в кассе предприятия и на расчетных счетах позволяет не только контролировать остатки

и исполнение обязательств предприятия но и планировать будущие платежи с помощью «платежного календаря»

и формирования бюджета движения денежных средств. Возможна интеграция с системами «Клиент-банк».

Кадры и расчеты по зарплате с персоналом:

в программе можно не только оформить прием на сотрудника работу, кадровое перемещение и отразить увольнение, но и осуществлять планирование и учет рабочего времени персонала.

Сравнивая фактическое время выполнения работы с нормативным можно проанализировать эффективность выполнения операций.

Учет основных средств и внеоборотных активов позволяет отразить как принять к учету актив, начислить амортизации так и изменить параметры амортизации.

Также можно отразить списание и продажу имущества.

Для управленческого учета на предприятии задействованы модуль учета расходов, доходов, прибыли и убытков.

Специализированные отчеты «Монитор руководителя» и «Монитор основных показателей» предприятия помогут своевременно увидеть как положительную так и отрицательную динамику.

С помощью гибкой системы настройки прав можно разграничить права, а встроенные возможности платформы 1с предлагают механизмы контроля за действиями пользователей.

Обмен данными с бухгалтерией предполагает исключение многократного ввода. И позволяет выгрузить необходимую информацию.

Совместно с программой можно использовать самое различное торговое оборудование. Начиная от фискальных регистраторов online-касс, заканчивая эквайринговыми терминалами

Программный продукт Альфа-Авто состоит из нескольких модулей:

Учет запчастей:

  • оптовая продажа запчастей;

  • розничная продажа запчастей;

  • работа по заказам запчастей;

  • закупки запчастей;

  • организация внутрифирменного товародвижения.

Учет в автосервисе:

  • планирование ресурсов;

  • оформление ремонтов;

  • автоматизированное рабочее место сотрудника автосервиса;

  • прием шин на хранение.

Учет в автосалоне

  • клиентские и складские заказы;

  • тест-драйв автомобилей; 

  • покупка и продажа автомобилей;

  • предпродажная подготовка автомобилей;

  • сделки «Trade-in»;

  • ответственное хранение автомобилей.

Финансовый блок:

  • оплаты покупателей и поставщикам;

  • ведение взаиморасчетов с подотчетными лицами;

  • бюджетирование.

Обмен данными:

  • обмен данными с бухгалтерскими системами;
  • обмен данными с каталогами производителей.

Осин Валерий Владимирович

Программист 1С Альфа-Авто

Образование.

Высшее.Ташкентский государственный технический университет.Факультет: Автоматизированные системы управления, Роботы и робототехнические системыСпециальность: Инженер-системотехникГод окончания: 1993.

Программист 1С Альфа-Авто: навыки и умения

Программное обеспечение

• Базы данных: Microsoft SQL Server, 1С, PostgreSQL/• Платформы: Microsoft Windows 2000, XP, 7, 8, 8.1, 10, Server 2003, Server 2008.Должностные обязанности• Администрирование и монтаж локальных, проводной и беспроводной, сетей.• Администрирование локального домена.• Администрирование Wi-Fi сети.• Администрирование и настройка роутеров (в т. ч. не сложная настройка роутеров MikroTik), организация доступа извне к определенные локальным сетевым ресурсам.• Установка и настройка системного и прикладного программного обеспечения.• Установка и настройка оргтехники, обслуживание системы видеонаблюдения и офисной телефонии.• Закупка ПК, оргтехники, программных продуктов.• Установка и настройка программных продуктов 1С, файловый и клиент-серверный вариант.• Программирование, изменение и адаптация программного обеспечения на платформе 1С.• Консультации, обучение и поддержка пользователей.

Иностранные языки: Английский (базовый).

Опыт работы:​

АвтоМаш-МБ ООО10.2018 — настоящее время

Программист 1С Альфа-Авто
  • Разработка программного обеспечения автоматизации автобизнеса на платформе 1С.
  • Консультации, обучение и поддержка пользователей.

Сайт компании: https://sales.mercedes-automash.ru

Альянс-Тракс ООО 11.2017 — 10.2018

Программист 1С Альфа-Авто
  • Разработка программного обеспечения автоматизации автобизнеса на платформе 1С.
  • Консультации, обучение и поддержка пользователей.

Сайт компании: http://www.alliance-trucks.ru/

ТоргМАШ ООО 08.2016 — 06.2017

Программист 1С Альфа-Авто
  • Разработка программного обеспечения автоматизации автобизнеса на платформе 1С.
  • Консультации, обучение и поддержка пользователей.
  • прием, хранение и выдача товарно-материальных ценностей;
  • отражение движение товаров в программе 1С;
  • учет, размещение товара;
  • участие в проведении инвентаризации;
  • ведение складской документации.

Сайт компании: http://torgmash-avto.ru/

Евро-Империал ООO 05.2008 — 04.2016

Системный администратор, Программист 1С Альфа-Авто

• Разработка и внедрение системы дисконтных карт.• Разработка маркетинговых программ по привлечению клиентов.• Формирование рекламного контента для сайта компании.• Число постоянных клиентов увеличено до 20%.

• Адаптация программного обеспечения под нужды компании.• Организация и внедрение IP-телефонии.• Проектирование и организация ЛВС.• Внедрение и увеличение автоматизации труда сотрудников компании.• Производительность труда увеличена на ~80%.

• Проектирование и организация ЛВС• Администрирование и монтаж локальных, проводной и беспроводной, сетей.• Администрирование локального домена.• Администрирование Wi-Fi сети.• Автоматизация труда 95% сотрудников.

Сайт компании: www.euro-imperial.ru

1C-Рарус ООО 03.2008 — 05.2008

Инженер — Программист 1С Альфа-Авто

• Разработка программного обеспечения автоматизации автобизнеса на платформе 1С.• Консультации, обучение и поддержка пользователей.

Сайт компании: https://rarus.ru/

Авто-Менеджмент ООО06.2007 — 03.2008

Начальник ИТО, Программист 1С Альфа-Авто

• Организация постоянного канала связи между центральным офисом и двумя филиалами.• Установка, унификация и взаимосвязь программного обеспечения центрального офиса и филиалов.• Адаптация программного обеспечения под нужды компании.• Внедрение и увеличение автоматизации труда сотрудников филиалов компании.• Проектирование и организация ЛВС.

Сайт компании: http://www.att-auto.ru/

Нормативно-справочная подсистема в 1С Автосервис

Отраслевая специфика требует учета и классификации автомобилей, для этого добавлен справочник моделей. Грамотное структурирование этого справочника позволит в дальнейшем проанализировать парк обслуживаемой техники. Выделение видов ремонта в отдельный справочник поможет не только определить платные и бесплатные услуги, но и определяет порядок взаиморасчетов и ценообразования.

В конфигурации присутствуют обработки для загрузки данных и норм времени выполнения авторабот позволяют интегрировать систему со следующими каталогами:

  • Silver-Dat II (файлы в формате szf),
  • Автонормы (файлы в формате xml),
  • Autodata (файлы в формате xml);
  • Autodata online (файлы в формате xml)

Этап 5. Регистр сведений «Контактная информация»

В модуле набора записей скорректировать процедуру:

Процедура ПередЗаписью(Отказ, Замещение)
	// проверка для предотвращения попытки полной зачистки регистра
	Если ЭтотОбъект.Количество() = 0 Тогда
		Если ОбЗначениеНеЗаполнено(ЭтотОбъект.Отбор.Объект.Значение) И
			ОбЗначениеНеЗаполнено(ЭтотОбъект.Отбор.Тип.Значение) И
			ОбЗначениеНеЗаполнено(ЭтотОбъект.Отбор.Вид.Значение) Тогда
			СтрокаОтказа = "";
			Отказ = Истина;
		КонецЕсли;
	КонецЕсли;
 
	// проверки оставлены в модуле на случай редактирования КИ в строке
	// Вообще проверка делается локально в каждой форме записи КИ
	Для Каждого Запись Из ЭтотОбъект Цикл
 
		Если ОбЗначениеНеЗаполнено(Запись.Объект) Тогда
			Отказ = Истина;
			СтрокаОтказа = "Не заполнено поле ""Владелец"". Запись невозможна!";
			Продолжить;
		КонецЕсли; 
 
		Если Запись.Объект.ЭтоГруппа Тогда
			Отказ = Истина;
			СтрокаОтказа = "Нельзя использовать группу в качестве объекта контактной информации.";
			Прервать;
		КонецЕсли;
 
		Если ОбЗначениеНеЗаполнено(Запись.Вид) Тогда
			Отказ = Истина;
			СтрокаОтказа = "Не заполнено поле ""Вид"". Запись невозможна!";
			Прервать;
		КонецЕсли;
 
		Если ОбЗначениеНеЗаполнено(Запись.Представление) Тогда
			Отказ = Истина;
			СтрокаОтказа = "Не заполнено представление контактной информации. Запись невозможна!";
			Прервать;
		КонецЕсли;
		//**********************************************************************
		// PT1C / начало редактирования
		// производим дозаполнение контактной информации
		# Если Клиент Тогда  
		Если Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон Тогда
			ПредставлениеБаза   = Запись.Представление;
			ПредставлениеНомера = Запись.Поле1 + Запись.Поле2 + Запись.Поле3;
			Если ЗначениеЗаполнено(Запись.Поле4) И НЕ ЗначениеЗаполнено(ПредставлениеНомера) Тогда
				Запись.CRM_ПолеХраненияНомера = CRMПреобразоватьНомерДляСохранения(Запись.Поле4,  глКоличествоХранимыхЦифрТелефона);
			ИначеЕсли НЕ ЗначениеЗаполнено(ПредставлениеНомера + Запись.Поле4) И ЗначениеЗаполнено(ПредставлениеБаза) Тогда	
				Запись.CRM_ПолеХраненияНомера = CRMПреобразоватьНомерДляСохранения (ПредставлениеБаза,  глКоличествоХранимыхЦифрТелефона);
			Иначе
				Запись.CRM_ПолеХраненияНомера = CRMПреобразоватьНомерДляСохранения (ПредставлениеНомера,  глКоличествоХранимыхЦифрТелефона);
			КонецЕсли;				
		КонецЕсли;
		// Для возможности сохранения Скайп номера, обойдем лишние проверки при изменении данных
		Если Найти(Запись.Вид,"Skype")>0 Тогда
			Запись.CRM_НомерТелефона = Запись.Представление;
		КонецЕсли;
		# КонецЕсли 
		// PT1C // окончание редактирования
		//**********************************************
	КонецЦикла;
 
	Если Отказ Тогда
		Сообщить(СтрокаОтказа);
	КонецЕсли;
 
КонецПроцедуры

Этап 4. Внесение изменений в глобальный модуль

Внесем доработки в «Модуль обычного приложения».

  1. В дереве объектом метаданных находим корневой узел.
  2. Правой кнопкой мыши открываем контекстное меню, выбираем «Открыть модуль обычного приложения».

Находим процедуру «ПриНачалеРаботыСистемы» и заменяем фрагмент исходного кода:

В актуальных релизах Альфа-авто 5.1.19+ инициализацию панели телефонии перенесли в общий модуль ЛицензированиеКлиентСобытия процедуру ПослеСтартаСистемыЗащитыОбычноеПриложение(). Создание обработки панели телефонии необходимо выполнять в указанной процедуре.

ИначеЕсли ТекАТС = Перечисления.CRM_ИспользуемыйСофтФон.СофтФонПроф Тогда
			Попытка
				РарусСофтФонПроф = Обработки.CRM_СофтФонПроф.Создать();
				РарусСофтФонПроф.ПодключитьСофтФон();

Следующим фрагментом:

ИначеЕсли ТекАТС = Перечисления.CRM_ИспользуемыйСофтФон.СофтФонПроф Тогда
			Попытка
				// МИКО / Панель телефонии Asterisk / НАЧАЛО
				// РарусСофтФонПроф = Обработки.CRM_СофтФонПроф.Создать();
				РарусСофтФонПроф = Обработки.МИКО_ПанельТелефонииДля1С.Создать();
				// МИКО / Панель телефонии Asterisk / КОНЕЦ
				РарусСофтФонПроф.ПодключитьСофтФон();

Далее находим процедуру «ОбработкаВнешнегоСобытия(Источник, Событие, Данные)» в конце процедуры, перед надписью «КонецПроцедуры» вставляем следующий код:

// Процедура выполняет обработку внешнего события
//
Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
 
	// *** *** *** //
 
	// МИКО / Панель телефонии Asterisk / Начало 
	Если НЕ РарусСофтФонПроф = Неопределено 
		 И (Источник = "MikoAjamEvent" ИЛИ Источник = "MIKO_SoftPhone" ИЛИ Источник = "hWindow") Тогда
		РарусСофтФонПроф.ОбработкаВнешнегоСобытияАстериск(Источник, Событие, Данные);
	КонецЕсли;
	// МИКО / Панель телефонии Asterisk / Конец
КонецПроцедуры

С этим читают